Jump to content


Acbr Nfe - Falha Na Validação Dos Dados Da Nota










12 respostas a este tópico

#1 luke

    Membro - Novato

  • Membros
  • Pip
  • 13 posts
  • Sexo:Masculino
  • Estado:Paraná

Adicionado 11 September 2009 - 09:29 AM

Bom dia,


Estou utilizando o Acbr Nfe com o Delphi 7 para gerar a Nfe. No entanto quando ele vai vailidar o xml aparece o seguinte erro "Element '{www.w3.org/2000/09/xmldsig#}X509Data' is unexpected according to content model of parent element '{www.w3.org/2000/09/xmldsig#}KeyInfo".

Segue em anexo um print do erro !


Será que alguem poderia me dar uma luz ae?



Lucas

Arquivo(s) anexo(s)



#2 Adilson Pazzini

    Membro - Junior 2

  • Membros
  • PipPipPipPip
  • 162 posts
  • Estado:São Paulo

Adicionado 11 September 2009 - 11:05 AM

Tenta Mandar Assinar antes ..

AcbrNFE.assinar ;
AcbrNFE.valida ;

Editado por Adilson Pazzini, 11 September 2009 - 11:05 AM.


#3 luke

    Membro - Novato

  • Membros
  • Pip
  • 13 posts
  • Sexo:Masculino
  • Estado:Paraná

Adicionado 11 September 2009 - 01:27 PM

Obrigado pela resposta Adilson.

Mas eu estou usando o comando AcbrNfe.Enviar(0);

Ou seja, esse comando faz tudo. Ele Gera, assina e envia.

Tentei fazer do jeito que vc disse e continua dando o mesmo erro

#4 Gr@c@

    Membro - Pleno 2

  • Membros
  • PipPipPipPipPipPipPip
  • 356 posts
  • Sexo:Feminino
  • Estado:Minas Gerais

Adicionado 11 September 2009 - 02:08 PM

Verifique se a sua pasta SCHEMAS está atualizada conf a ultima revisão do SVN

View Postluke, on 11 September 2009 - 01:27 PM, said:

Obrigado pela resposta Adilson.

Mas eu estou usando o comando AcbrNfe.Enviar(0);

Ou seja, esse comando faz tudo. Ele Gera, assina e envia.

Tentei fazer do jeito que vc disse e continua dando o mesmo erro


#5 luke

    Membro - Novato

  • Membros
  • Pip
  • 13 posts
  • Sexo:Masculino
  • Estado:Paraná

Adicionado 11 September 2009 - 02:51 PM

View PostDangra, on 11 September 2009 - 02:08 PM, said:

Verifique se a sua pasta SCHEMAS está atualizada conf a ultima revisão do SVN

Boa Tarde,

Atualizei a pasta Schemas e o erro continuou,

Ele da esse erro qndo chega nessa parte da unit AcbrNfeUtil

Schema := CoXMLSchemaCache50.Create;
if Tipo = 1 then
Schema.add( 'http://www.portalfiscal.inf.br/nfe', ExtractFileDir(application.ExeName)+'\Schemas\nfe_v1.10.xsd')
else if Tipo = 2 then
Schema.add( 'http://www.portalfiscal.inf.br/nfe', ExtractFileDir(application.ExeName)+'\Schemas\cancNFe_v1.07.xsd')
else if Tipo = 3 then
Schema.add( 'http://www.portalfiscal.inf.br/nfe', ExtractFileDir(application.ExeName)+'\Schemas\inutNFe_v1.07.xsd');
DOMDocument.schemas := Schema;
ParseError := DOMDocument.validate;
Result := (ParseError.errorCode = 0);
Msg := ParseError.reason;


#6 juaumkiko

    Membro - Senior 3

  • Membros
  • PipPipPipPipPipPipPipPipPip
  • 1575 posts
  • Sexo:Masculino
  • Estado:São Paulo

Adicionado 11 September 2009 - 03:11 PM

Posta o XML para analise.

[]´s

#7 luke

    Membro - Novato

  • Membros
  • Pip
  • 13 posts
  • Sexo:Masculino
  • Estado:Paraná

Adicionado 11 September 2009 - 03:14 PM

View Postjuaumkiko, on 11 September 2009 - 03:11 PM, said:

Posta o XML para analise.

[]´s


Oh o XML ae gnte !!

Arquivo(s) anexo(s)



#8 juaumkiko

    Membro - Senior 3

  • Membros
  • PipPipPipPipPipPipPipPipPip
  • 1575 posts
  • Sexo:Masculino
  • Estado:São Paulo

Adicionado 11 September 2009 - 03:25 PM

O seu XML esta validando normalmente pelo DEMO aqui.

Veja se no seu DEMO ae ele é validado tb. (botao VALIDAR XML)

[]´s

#9 luke

    Membro - Novato

  • Membros
  • Pip
  • 13 posts
  • Sexo:Masculino
  • Estado:Paraná

Adicionado 11 September 2009 - 03:44 PM

View Postjuaumkiko, on 11 September 2009 - 03:25 PM, said:

O seu XML esta validando normalmente pelo DEMO aqui.

Veja se no seu DEMO ae ele é validado tb. (botao VALIDAR XML)

[]´s


Opa

Aqui no meu demo do acbr ele deu msmo erro

Será que o problema tá no meu componente?

#10 juaumkiko

    Membro - Senior 3

  • Membros
  • PipPipPipPipPipPipPipPipPip
  • 1575 posts
  • Sexo:Masculino
  • Estado:São Paulo

Adicionado 11 September 2009 - 03:49 PM

Atualize o componente e teste.

#11 luke

    Membro - Novato

  • Membros
  • Pip
  • 13 posts
  • Sexo:Masculino
  • Estado:Paraná

Adicionado 11 September 2009 - 04:04 PM

View Postjuaumkiko, on 11 September 2009 - 03:49 PM, said:

Atualize o componente e teste.

Atualizei e Reinstalei, mesmo erro.

Tanto no projeto qnto no demo.

Será que naum eh a versão da pasta Schemas?

#12 luke

    Membro - Novato

  • Membros
  • Pip
  • 13 posts
  • Sexo:Masculino
  • Estado:Paraná

Adicionado 14 September 2009 - 07:45 AM

Pessoal, continuo com o mesmo problema ainda !!

#13 alexlops

    Membro - Novato

  • Membros
  • Pip
  • 3 posts
  • Estado:Other Countries

Adicionado 22 September 2009 - 05:02 PM

Também estou com o mesmo problema, quando gero o arquivo xml e importo pelo programa da receita dá esse erro alguém sabe como resolver ?
Porém no validador da ACBRNFe ele passa sem problemas....Attached File  35090905147464000149550030000001940000000061-NFe.xml   2.22K   6 Número de Downloads





1 usuário(s) esta(ão) lendo este tópico

0 membro(s), 1 visitante(s) e 0 membros anônimo(s)